Netgear WGT634u as a Wireless Client Running OpenWRT Backfire

Posted by Max Power | Posted in Netgear WGT634u | Posted on 14-04-2012-05-2008

0

In this post I will show how to configure your Netgear WGT634u, running OpenWRT Bsckfire, as a wireless client.  This means that it will allow devices connected to its LAN to be connected to a wireless router LAN.

  1. First you will have to enable the wireless as shown in this post.
  2. On the LuCI>Network>wifi>wifi0 device info set the network to “WAN” and mode to “client“.

Here are my config files for reference (/etc/config/):

Wireless

config 'wifi-device' 'wifi0'
	option 'type' 'atheros'
	option 'channel' 'auto'
	option 'diversity' '0'
	option 'disabled' '0'
 
config 'wifi-iface'
	option 'device' 'wifi0'
	option 'ssid' 'ssid'
	option 'network' 'wan'
	option 'mode' 'sta'
	option 'encryption' 'wep'
	option 'key' '******************'

Network

config switch eth0
	option enable 1
 
config switch_vlan eth0_0
	option device "eth0"
	option vlan 0
	option ports "0 1 2 3 5"
 
config switch_vlan eth0_1
	option device "eth0"
	option vlan 1
	option ports "4 5"
 
config interface loopback
	option ifname "lo"
	option proto static
	option ipaddr 127.0.0.1
	option netmask 255.0.0.0
 
config interface lan
	option type bridge
	option ifname "eth0.0"
	option proto static
	option ipaddr 192.168.1.1
	option netmask 255.255.255.0
 
config interface wan
	option ifname "eth0.1"
	option proto dhcp

Write a comment